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SurPro6.0 Software Overview 

1.1 Software Introduction 

SurPro6.0 software is GUANGZHOU ALPHA GEO-INFO CO.,LTD. developed based on GNSS hi

gh-precision location application development of engineering surveying application software, devel

opers according to years of mapping development and market experience accumulation, combined 

with a large number of industry users using habits and Android operating style habit fusion, Develo

ped high-precision position measurement and acquisition, point line stake, road design stake, CAD 

and other powerful and simple operation of engineering measurement application software.The soft

ware has the characteristics of simple operation and user-friendly operation process, powerful road 

design and construction stake function, powerful CAD drawing stake function, functional menu dis

play is convenient for users to customize design and so on. 

The following describes the basic functions of the software: The software mainly includes four parts:

 project, instrument, measurement and tool. 

1.1.1 Project 

This part is mainly for project configuration, project data management and software Settings and 

other related operations, mainly including project management, calculation of conversion 

parameters, base station translation calibration, coordinate system parameter setting, coordinate 

point library, code library management, survey area setting, conversion setting, software and other 

functions. 

1.1.2 Device 

This part is mainly aimed at the operation related to the connection of high-precision GNSS 

equipment and equipment setting, mainly including communication setting, mobile station mode 

setting, reference station mode setting, static mode setting, instrument information viewing, 

instrument setting, satellite star map star map and positioning information viewing. 

1.1.3 Survey 

This part mainly uses GNSS position to carry out field data measurement, stake and other 

operations related to industry application, mainly including point measurement, fragment 

measurement, control point measurement, point stake, CAD, linear stake, site elevation control, 

road design stake, GIS data collection and other functions. 

1.1.4 Tools 

This part is mainly related to the measurement of some common practical tools, mainly including 

coordinate conversion, Angle conversion, perimeter area calculation, calculator and other functions. 

1.2 Software Installation and uninstallation 

Installation process: 

1. Download android SurPro6.0 software installation (*.apk). 
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2. Copy the SurPro6.0 software installation program to your mobile phone (Handheld) device. Find 

the software installation in file Management on your handheld device and click the installer to instal

l it. 

3. Click the desktop SurPro6.0 software to enter the software (you need to create a project when ent

ering the software for the first time, and it will automatically open the software and use the project a

fter each startup). 

Uninstallation process: 

Uninstall Method 1: Hold down the software icon on the desktop, drag it to the Uninstall option box,

 and click OK to uninstall the software. 
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Project 

The main window is displayed. Click Project.Figure 2-1 shows the corresponding menu. The projec

t includes project management, localization, calibrate point, coordinate system, point database, code

 library management, survey range settings, software setting, about software and other functions. 

  

Figure 2-1 

All data and operations of the software are stored and managed by engineering pr

ojects. After entering the software for the first time, you must create a projec

t first. After entering the software each time, the software will automatically 

load the project used for the last time. Each Project is stored in the correspon

ding directory (default location: Internal storage ->SurPro->Project) as a Proje

ct name folder. The basic information of the Project is stored in Project name.j

ob, and other data is stored in the corresponding directory file. 

2.1 Project Management 

Click [Project] -> [Project Management], as shown in Figure 2.1-1. Project management includes cr

eating a project, removing a project, opening a project, and opening a disk project that is not in the l

ist. 

Click the item shown in the item list, and the functions of remove and open will appear, as shown in

 Figure 2.1-2. Click Remove, as shown in Figure 2.1-3, to remove the project from the list. If you se

lect Delete data file at the same time, the data on the disk of the project will be deleted; if you do no
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t select delete data file at the same time, the project will only be removed from the list, and you can 

open the project in other projects later, as shown in Figure 2.1-4. 

Click New Project, as shown in Figure 2.1-5. To create a Project, you need to fill in the Project nam

e, operator, Project description and other basic information of the Project. You can also modify the 

path of the Project in disk (internal storage ->SurPro->Project by default), click Next, and fill in the 

coordinate system parameters used by the Project. As shown in Figure 2.1-6, click Finish to comple

te the new project. 

     

Figure 2.1-1                   Figure 2.1-2                  Figure 2.1-3 
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Figure 2.1-4                   Figure 2.1-5                  Figure 2.1-6 

2.2 Localization 

Click [Project] -> [Calculate conversion parameters], as shown in Fig.2.2-1.The high-precision posi

tion obtained by the software from GNSS equipment is the longitude and latitude coordinates of sat

ellite positioning, but in actual engineering operations, the plane coordinates of the ground are ultim

ately needed for measurement and application.If the customer has coordinate conversion parameters,

 the coordinate system parameter values can be directly set in the coordinate system (Detail 2.4). If t

he customer does not have specific coordinate system parameters, but the corresponding values of l

ongitude and latitude coordinates and plane coordinates are called control points. In the case of cont

rol point data, conversion parameters can be calculated by this function and applied to engineering p

rojects. 

In conversion parameter management, you can manually add control points, as shown in Figure 2.2-

2. You can also import control point parameters in multiple formats, as shown in Figure 2.2-3. The 

commonly used formats are listed. You can set a format to be commonly used or not, as shown in Fi

gure 2.2-4, or add a custom format, as shown in Figure 2.2-5. In the control point list, click the data 

item to enter modify edit control point parameters. You can hold down a data item to select multiple

 data items and delete all data items, as shown in Figure 2.2-6. You can also export control point dat

a to a file and provide it to third-party software. 

After editing the control point parameters, calculate the conversion parameters of the control point a

nd click "Calculate" to pop up the setting of calculation parameters, as shown in Fig.2.2-7. The para

meter conversion process includes ellipsoid datum conversion, horizontal correction and vertical cor
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rection. The conversion parameters that can be calculated may be all or part of the combination. The

 calculated conversion parameters are considered usable as long as the corresponding accuracy is ac

hieved within the permissible accuracy range. Ellipsoid reference conversion is usually seven param

eters, which is the conversion parameter of spatial rectangular coordinates between two ellipsoids. 

Horizontal correction method includes four parameters and horizontal difference parameters, and el

evation correction method includes weighted average, plane fitting, surface fitting and vertical plane

 error. Under normal circumstances, if the operation scope is very wide, it is necessary to use ellipso

idal datum conversion to meet the accuracy requirements of all control points; if the operation scope

 is relatively small, the corresponding accuracy can be achieved by plane correction. 

After the calculation conditions are configured, click OK to display the calculation results of conver

sion parameters, as shown in Figure 2.2-8. After the conversion parameters are calculated, the calcu

lation report can be exported for project review and inspection. If the conversion parameters are qua

lified, the parameters can be applied to the engineering project, and the normal measurement operati

on can be carried out. 

     

Figure 2.2-1                 Figure 2.2-2                    Figure 2.2-3 
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Figure 2.2-4               Figure 2.2-5                 Figure 2.2-6 

   

Figure 2.2-4              Figure 2.2-5 
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2.3 Calibrate Point 

Click on [project] - > calibrate point, as shown in figure 2.3 1, in the process of practical application,

 GNSS difference data combined solution of equipment through the base station is of high precision

 position, here we know reference station coordinates is known, in fact, the output of high-precision 

GNSS equipment location is the relative position of base station.In the actual application process, a

part from some users using the differential data of CORS reference station, a considerable number o

f users also use the differential data of reference station transmitted by their own GNSS equipment. 

When transmitting differential data by their own station construction, a project may involve multipl

e startup of reference station, and when starting reference station, The start position and start the bas

e station coordinates may change, and start the coordinates are not necessarily the right, in the case 

of without calibration, use these stations difference of mobile station coordinates would be a mistak

e (in the same place, the use of differential data measurement and the coordinates of the new differe

ntial data before get the coordinates of the different). Therefore, translation calibration is required w

hen the mobile station receives the differential data of the new base station for measurement operati

ons, so that the coordinates obtained by the software are matched with those obtained by connecting

 the last base station. 

After the starting coordinate or starting position of the base station changes, it is necessary to use a 

known position to calibrate the coordinates correctly.Select a known point in the point library (usin

g the coordinates measured at a certain position of the last base station), then put GNSS equipment 

at the position of the known point to measure a new anchor point and calculate the deviation, as sho

wn in Figure 2.3-2.After the point is determined, the coordinates received by the software are match

ed with those measured last time. 

Base station coordinates changes remind whether to recalibrate. If it is to receive differential signals

 from self-built reference stations, base station coordinates change, indicating that base station transl

ation calibration needs to be carried out, and translation calibration needs to be recalibrated. 

Note: THE CORS reference station is a long running reference station whose position and starting c

oordinates do not change. If the differential data of the CORS reference station is used, the obtained

 coordinates will be correct even though the received coordinates may change, without translation c

alibration. 
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Figure 2.3 1               figure 2.3 2 

2.4 Coordinate System 

Click [Project] -> [Coordinate System], as shown in Figure 2.4-1. The coordinate system parameter

s are to convert the longitude and latitude coordinates received by GNSS equipment to the plane co

ordinates required by users through certain algorithm calculation. This calculation is converted to se

t corresponding parameters. The whole calculation conversion process is as follows: 

1. Original latitude and longitude coordinates -> Spatial cartesian coordinates of the WGS84 ellipso

id: use the WGS84 ellipsoid parameter; 

2. Spatial cartesian coordinates of WGS84 ellipsoid -> Spatial cartesian coordinates of target ellipso

id: use datum conversion parameters; 

3. Spatial cartesian coordinates of target ellipsoid -> Target latitude and longitude coordinates: use t

arget ellipsoid parameters; 

4. Target latitude and longitude coordinates -> Projection plane coordinates: use target ellipsoid + p

rojection parameters; 

5, projection plane coordinates -> target plane coordinates: use plane correction + vertical correctio

n parameters; 

Click "Ellipsoid Parameters" to enter the ellipsoid management interface, as shown in Figure 2.4-2. 

Select the required ellipsoid from the ellipsoid list. You can also add or delete ellipsoid parameters. 

Click "Projection Parameters" to enter the interface for editing projection parameters, as shown in F

igure 2.4-3. You can choose gaussian projection, UTM projection, Mercator projection, tilted stereo
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graphic projection, double stereographic projection, etc. If it is gaussian projection, enter the correct

 central meridian, north plus constant, east plus constant, projection scale, datum latitude and other 

parameters. 

Click "Datum Parameters" to enter the interface for editing datum conversion parameters, as shown 

in Figure 2.4-4. The transformation models include Boolean sand, Boolean sand (with origin param

eters), Boolean sand strict algorithm, Helmert, three-parameter transformation models, etc. 

Click "Horizon Adjustment" to enter the interface for editing plane correction parameters, as shown

 in Figure 2.4-5. The transformation model includes four parameters and horizontal adjustment mod

el. Also support grid conversion file conversion, import grid offset file, according to the transition p

oint in the grid position, to correct the coordinates. 

Click "Vertical Adjustment Parameters" to enter the interface for editing vertical correction paramet

ers, as shown in Figure 2.4-6 and 2.4-7.The transformation model includes fixed error, surface fittin

g and vertical adjustment model.Also support geoid file conversion, import geoid file, according to t

he conversion point in the level position, to correct the coordinate elevation.Levelling file managem

ent interface, as shown in Figure 2.4-8, allows users to import and remove levelling files and set par

ameters by selecting required levelling files. 

Click "Local Offsets" to enter the local offsets editing interface. In small scale jobs, sometimes ther

e is only one control point, and you just need to translate from the projected plane coordinates to the

 target plane coordinates, which can be set here. The difference between translation parameters here

 and base station translation calibration is that coordinate system parameter setting here will affect a

ll data of the whole project. If there is any change, the transformation of longitude and latitude coor

dinates and plane coordinates will be recalculated, while base station translation calibration will onl

y affect the measurement coordinates after calibration operation. 

In addition to manually entering coordinate system parameters, you can also click after the name

, select coordinate system parameters from the list of commonly used coordinate systems. Com

mon coordinate system management can be added, imported, or selected from a template, or remov

ed from the list with a long press. 
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Figure 2.4-1 Figure 2.4-2 Figure 2.4-3 

    

Figure 2.4-4             Figure 2.4-5                 Figure 2.4-6 
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Figure 2.4-7                Figure 2.4-8                 Figure 2.4-9 

2.5 Points Database 

Click [Project] -> [Points Database], as shown in Figure 2.5-1. Here you can view and manage the p

oint data in the project, including adding, deleting, restoring, viewing point details, importing, expor

ting and other functions. 

Add: as shown in Figure 2.5-2, manually input roll call, code and corresponding coordinates; 

Delete: As shown in Figure 2.5-3, you can hold down and select points in batches to delete. 

Recover: Restore the point data that is mistakenly deleted, as shown in Figure 2.5-4. 

View point details: Click the data item in the list to view point details, as shown in Figure 2.5-5 (sm

ooth point) and 2.5-6 (control point). You can also modify the roll call code information, and for co

ntrol points, you can also export from here to generate control point reports. 

Import: Select the format of the data to be imported, and select a data file to import the data, as sho

wn in Figure 2.5-7. You can also set common formats and add or delete custom formats in format m

anagement. 

Export: Select the data format, location, and file name, and click Export to export data, as shown in 

Figure 2.5-8. If you choose to export multiple formats, it will be generated in a folder. 
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Figure 2.5-1                Figure 2.5-2                 Figure 2.5-3 

 

Figure 2.5-4                 Figure 2.5-5                  Figure 2.5-6 
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Figure 2.5-7            figure 2.5-8 

2.6 Code library management 

Click "Project" -> "Code Library Management", as shown in Figure 2.6-1. The code base is pre-defi

ned by the code attributes of the external collection points, and the code values are quickly filled in 

by the choice of the image name description. 

In code library management, as shown in Figure 2.6-2, select the code library to be used by the proj

ect. You can import the code library, as shown in Figure 2.6-3, or manually add the code library, as 

shown in Figure 2.6-4 and 2.6-5. In addition to filling the code in the collection point, the same cod

e value can also be set for automatic mapping, which can quickly and conveniently measure the gro

und object icon of straight line and line removal type. 
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Figure 2.6-1                 Figure 2.6-2               Figure 2.6-3 

 

Figure 2.6-4           figure 2.6-5 
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2.7 Survey Range Settings 

Click [Project] -> [Survey Range Settings], as shown in Figure 3.7-1. The function is to determine 

whether the current positioning position is within the range of the measurement area in real time by 

setting a certain range of coordinates in the process of field measurement. If it is beyond the range, i

t will timely remind the user of the scope of the work beyond the scope, so as to avoid the user to do

 the work beyond the scope of work. 

Edit and manage the test range, including adding coordinates, batch selecting from the point databas

e, as shown in Figure 2.7-2, and importing and exporting the coordinates of the test range. You can 

view a preview of the test area, as shown in Figure 2.7-3. 

 

FIG. 2.7-1               FIG. 2.7-2                     FIG. 2.7-3 

 

2.8 Software Settings 

Click [Project] -> [Software Settings], as shown in Figure 2.8-1, 2.8-2, 2.8-3, 2.8-4. The settings inc

lude system Settings, display Settings, voice prompt Settings, and shortcut key Settings. 

System Settings: As shown in Figure 2.8-1, the settings mainly include length unit, Angle display fo

rmat, mileage display format, language, and text coding. 

Display setting: as shown in Figure 2.2-2, it mainly includes mapping display of measurement data, 

display sequence of north coordinate and east coordinate in the database, interface style, screen dire

ction and other Settings. 
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Shortcut key Settings: As shown in Figure 2.8-4, the manual physical keyboard is predefined to trig

ger corresponding functions, and shortcut keys are added, as shown in Figure 2.8-5. Select a functio

n for which you want to define a shortcut key and set a shortcut key. This function can be triggered 

quickly during application measurement. You can also hold down and delete defined shortcut keys. 

 

Figure 2.8-1              Figure 2.8-2                  Figure 2.8-3 
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Figure 2.8-4                figure 2.8-5 

2.9 About Software 

Click [Project] -> [About Software], as shown in Figure 2.9-1. Software registration and authorizati

on information, software version information, copyright information, etc. Here you can activate aut

horization, transfer authorization, check the new version and give feedback. 

Software activation: Enter the entitlement code or scan the QR code to activate the software, as sho

wn in Figure 3.9-2. 

Check the new version: if there is a new version, the new version information will pop up. Click Up

date to update the software to the latest version. If there is no new version, a message is displayed in

dicating the latest version. 

Feedback: As shown in FIG. 3.9-3, in order to provide better services to users, if you have any probl

ems during the use of the software, you can feedback the problems to our technology through here, 

and we will provide you with immediate support. Note: Be sure to leave your contact information 

(mainly email), the problem description is as complete as possible, if there is any attachment (icon, 

video, document, etc.), you can submit it together, thank you! 
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Figure 2.9-1               Figure 2.9-2                  Figure 2.9-3 
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Device 

On the main interface of the software, click the corresponding function menu of [Device], as shown 

in Figure 3-1 and 3-2. The instrument includes communication setting, mobile station mode, base st

ation mode, static mode, instrument information, instrument registration and other functions. 

 

Figure 3-1           Figure 3-2 

The data measurement, collection and application of the software are based on the application of G

NSS high-precision position. Before operation, it is necessary to establish communication with GN

SS positioning equipment. The software obtains high-precision position from the equipment, and th

e equipment also needs certain conditions to obtain high-precision position, and equipment paramet

ers need to be configured. 

3.1 Communication 

Click [Device] -> [Communication], as shown in FIG. 3.1-1. Select the instrument manufacturer, in

strument type and connection mode, then select the device parameters, and click "Connect" to comp

lete the device connection. After the device is successfully connected, the main window of the soft

ware is displayed, as shown in Figure 3-2. Then enter communication Settings, as shown in FIG. 3.

2-2, and click to stop cross-sectional device connection. 

1. Device manufacturer: The software supports access of positioning equipment from GNSS instru

ment manufacturers such as Topcon, Sokkia, Trimble, Emlid, ect as shown in Figure 3.2-3. 

2, Device type: usually RTK, some manufacturers of equipment according to the equipment model. 
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3, Connection type: WIFI connection, serial port connection, TCP client connection, etc., which ma

y be supported by different instrument manufacturers. The basic Bluetooth mode is basically suppor

ted by all manufacturers. 

4. Click ‘update’ to enter Bluetooth search and selection, as shown in FIG. 3.1-4. Click device to sel

ect the device to be connected. 

5. After the device is successfully connected, click "Debug" to view the data of communication bet

ween the software and the device, as shown in Figure 3.1-4. Debugging commands can be sent to th

e device to troubleshoot problems related to device positioning through the communication data. 

 

Figure 3.1-1              Figure 3.1-2                   Figure 3.1-3 
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Figure 3.1-4            Figure 3.1-5 

3.2 Rover 

Click [Device] -> [Rover], as shown in FIG. 3.2-1.GNSS positioning device can be calculated by sa

tellite reception positioning coordinates, in the case of no other conditions, due to the effect of atmo

sphere of signal positioning device can only get a single point in the coordinates of the location, the 

accuracy is not high, in order to ensure the GNSS can get high precision position, in addition to GN

SS satellite reception decoding position with the device itself, Also need to receive another near the 

fixed position of GNSS signal equipment, signal as reference signal to another device, because of th

e influence of the atmosphere to the signal in a certain region within the scope of basic consistent, r

eference signal in the condition of known coordinates, two groups of GNSS calculated can be high 

precision position, fixed position of GNSS device known as the base station, GNSS equipment with

 unfixed position is called mobile station. Compared with GNSS satellite signal of mobile station, d

ata transmitted from reference station is called differential data, and data transmission mode is calle

d data chain. The setting of mobile station mode is to set GNSS as mobile station and configure cert

ain parameters to transmit GNSS satellite signals of the reference station to the GNSS equipment in 

a certain way, so that the GNSS equipment can obtain high-precision positioning position. 

In addition to differential data transmission configuration, basic parameters such as height cutoff An

gle of GNSS and whether PPK is enabled can also be set. Click basic parameter content to enter the 

parameter editing interface, as shown in Figure 3.2-2. When the altitude Angle is lower than a certai

n value, the satellite signal can not be received. In the case of poor satellite signal at a low Angle, it 

is conducive to precision calculation. The PPK parameter is to record the original GNSS observatio



SurPro6.0 User Manual 

23 

 

n data to the GNSS receiver and use the post-processing algorithm to calculate the high-precision co

ordinates. 

 

Figure 3.2 1            figure 3.2 2 

Differential data parameter setting is mainly to set that the differential data of the reference station 

will be transmitted to the current equipment in some way, so as to provide necessary calculation con

ditions for the equipment to solve high-precision coordinates. Data link mode mainly includes built-

in radio, external radio, host network, notebook network and so on. Among them: 

1. Built-in radio: as shown in Figure 3.2-1, the built-in radio of GNSS equipment receives differenti

al data of the radio station according to a certain protocol and frequency for high-precision calculati

on. Click Parameters to modify and edit the parameters, as shown in Figure 3.2-3. Ensure that the pr

otocol and frequency of the radio station are consistent with that of the transmitting radio station, so

 that the data of the normal receiving radio station can be received. If the frequency corresponding t

o the channel is inconsistent with that of the transmitting radio station, click "Default Station Settin

gs" to modify the frequency corresponding to each channel of the radio station, as shown in Figure 

3.2-4. Click on the icon You can select the channel frequency configuration from the predefined 

channel management list, as shown in Figure 3.2-5. 

2. External radio: as shown in FIG. 3.2-6, GNSS equipment connects to external independent radio 

equipment through serial port. After receiving differential data from external radio equipment, it is t

ransmitted to GNSS equipment for high-precision calculation. Click Parameter to modify and edit t

he serial port baud rate parameters. In addition to ensuring that the serial port parameters of the devi



SurPro6.0 User Manual 

24 

 

ce connecting to the external radio are correct, ensure that the protocol and frequency of the externa

l radio are consistent with that of the transmitting radio. 

3. Host network: as shown in Figure 3.2-7, it refers to obtaining differential data from the specified 

server address according to a certain protocol through the SIM card network of GNSS equipment fo

r high-precision calculation. Click Parameters to modify and edit the parameters, as shown in Figure

 3.2-8. When the connection mode is differential data transmission protocol, NRTIP and TCP client 

are used to input the server IP address, port number, user name and password. The SIM network is a

 dedicated network, and APN parameters need to be set. CORS server parameters can be selected fr

om the server management list, as shown in Figure 3.2-9. After the server address is correctly confi

gured, obtain the access point list and select the corresponding access point to obtain differential dat

a. In addition to obtaining an access point from the host network, you can also obtain the access poi

nt from the corresponding network of a mobile phone. 

4. Manual network: as shown in Figure 3.2-10, differential data is obtained from the specified serve

r address according to a certain protocol through the network of the device where the software is loc

ated, and then sent to the device through the communication connection between the software and G

NSS equipment for high-precision calculation. Click Parameters to modify and edit the parameters. 

The parameter Settings are similar to those of the host network. You do not need to configure APN 

parameters. Click start connection, if the configuration is ok, the data receiving progress bar will mo

ve around. If the progress bar has no data, check whether the parameters are correctly configured. 

Note: built-in radio and external radio data link can be set whether the base station coordinate chang

e reminder, mainly because the radio is a one-way transmission, there may be more of the same freq

uency radio source, can lead to a radio signal gathering, if the received signal, the other may result i

n inaccurate coordinates, to remind the user to check. 
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Figure 3.2-3                Figure 3.2-4                 Figure 3.2-5 

 

Figure 3.2-6               Figure 3.2-7                Figure 3.2-8 
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Figure 3.2-9               Figure 3.2-10               Figure 3.2-11 

3.3 Base 

Click [Device] -> [Base], as shown in FIG. 3.3-1. The function is that GNSS equipment acts as a ref

erence station to send satellite information data in a certain way and provide it to the mobile station 

for reception, providing high-precision calculation conditions. It is necessary to set up the starting c

ondition parameters, starting mode and data broadcast parameters of the base station. 

Note: The device is not allowed to move during the base station startup, otherwise the coordinates c

alculated by the mobile station will be wrong. 

Start conditions include base station ID, height cutoff Angle, differential data format, PDOP limit, d

elay start and other parameters. Click the parameter content to enter the parameter editing interface, 

as shown in Figure 3.3-4. Differential data formats include RTCM2.3, RTCM3, CMR, CMR+, DG

PS, RTCM3.2 and other commonly used differential data encoding formats. 

The startup mode includes single point positioning startup, designated base station coordinate startu

p, and measuring point coordinate startup, among which: 

1. Single point positioning startup: it means that GNSS equipment outputs differential broadcast dat

a for startup coordinates according to the current positioning value (low accuracy); 

2. Start with specified coordinates: as shown in FIG. 3.3-2, it means that the early user knows the co

ordinate position in advance according to the location of the equipment, and uses the coordinate val

ue as the starting coordinate to output differential broadcast data;Click the coordinate parameter con

tent to enter the parameter editing interface, as shown in Figure 3.3-5.You can click on the The 

measurement icon measures a point in real time, or you can click on the coordinate content to select

 a coordinate value from the point library. 
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3. Positioning coordinates of measuring points, as shown in FIG. 3.3-3, means that the user collects 

a real-time point according to the positioning data of the current GNSS equipment and certain colle

ction and measurement conditions, and starts the real-time point according to the specified coordina

tes. Click the parameter content to enter the parameter editing interface, as shown in FIG. 3.3-6. 

Differential data parameters are mainly the differential data output by the device after the base stati

on is started and transmitted in certain ways, which are received and used by the mobile station. The

 main ways include host network, built-in radio, external radio and dual-transmission combination. 

Parameter Settings are similar to those of mobile stations, the differences are as follows: 

1. Built-in radio will have transmitting power. The higher the transmitting function, the farther the d

istance and the greater the power consumption. 

2. For host network NTRIP protocol, the base station is to set the access point for starting transmissi

on, while the mobile station is to obtain the access point list and select the corresponding base statio

n access point for connection, as shown in Figure 3.3-2. 

3. The reference station uses the manual network to broadcast differential data independently. 

 

Figure 3.3-1             Figure 3.3-2                  Figure 3.3-3 
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Figure 3.3-4 Figure 3.3-5 Figure 3.3-6 

3.4 Static 

Click [Device] -> [Static], as shown in Fig.3.1-1. The purpose of this function is to store the origina

l satellite observation data of GNSS equipment in the setting disk file, record the observation data o

f one time for solving the high-precision coordinate position with static post-processing software, us

ually used for control point acquisition. Static file roll call, PDOP limit, height cutoff Angle, acquisi

tion interval, antenna parameters and other recording conditions need to be set. 
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Figure 3.4 1 

Note: During static recording, the device is not allowed to move, otherwise it will lead to the coordi

nate error calculated after processing. 

4.5 Device Information 

Click [Device] -> [Device Information], as shown in Fig.4.5-1. You can view basic information abo

ut GNSS devices, such as the instrument serial number, firmware version, mainboard type, and mai

nboard serial number. 
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Figure 3.5 1 

3.6 Device Activation 

Click [Device] -> [Device Activation], as shown in Fig.4.5-1.If the GNSS equipment has expired, y

ou can obtain the registration authorization code from the dealer and register the equipment here. 
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Figure 3.6 1 

3.7 other 

1. Click the "battery quantity Icon" in the title bar of the software , you can view the battery statu

s, as shown in Figure 3.7-1. 

2. Click on the title bar of the software To enter the communication setting function, as shown 

in Figure 3.1-1. 

3. Click on the title bar of the software You can view the location coordinates output by the de

vice, as shown in Figure 3.7-2. You can view the base station information and star map and star tabl

e information, as shown in Figure 3.7-3, 3.7-4, and 3.7-5. As the antenna parameters of the base stat

ion are not transmitted in the differential data, only the phase center coordinates of the base station a

re transmitted. In order to get the ground coordinates corresponding to the starting of the base statio

n, the antenna parameters corresponding to the base station can be input. 

4. Click on the title bar of the software You can view the information received by the device 

satellite, as shown in Figure 3.7-5. 

5. Click "Settings" in the title bar of the star map star list to set the switch of the satellite system, as 

shown in Figure 3.7-6. 



SurPro6.0 User Manual 

32 

 

 

Figure 3.7-1              Figure 3.7-2                   Figure 3.7-3 

 

Figure 3.7-4                   Figure 3.7-5              Figure 3.7-6 
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Survey 

On the main interface of the software, click [Survey], as shown in Figure 4-1. It includes point surv

ey, detail survey, control point survey, point stakeout, CAD, line stakeout, DSM stakeout, Stake roa

d, polyline survey, polygon survey and function customization (GIS). 

 

Figure 4-1 

In the software, the project is the engineering data management and parameter configuration, for the

 field measurement function to do the necessary preparation and the measurement results of the data

 export; Instrument is the basic necessary condition for software to obtain high-precision position; A

nd measurement is the main work of the software, which deals with what to do with high-precision 

coordinates and how to do it. 

4.1 Survey 

Click [Survey] -> [Point Survey], as shown in Fig.4.1-1.The positioning of GNSS equipment output

 is measured and collected according to certain precision limitation conditions and stored in coordin

ate point database.In the point measurement interface, the title bar displays the basic positioning inf

ormation output by the current GNSS device, including the current solution state, difference delay, 

HRMS, VRMS and other positioning accuracy evaluation values, as well as the number of receiving

 satellites.Below the title bar is displayed in the status bar, other important information display cont

ent can be set according to user's interest in the set, the default display in the north east high in point

 measurement coordinates and the distance from the base station information, the middle area is me

asured data mapping information, also can set the display network map, drawing area in the top righ
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t corner of the electronic compass for hand thin compass shows, It is convenient for users to judge t

he direction when needed.Painting area, according to the left here are functions of the acquisition of

 these functions can also according to the needs of the user in the Settings menu will display the req

uired functionality here fast operation certain functions, area of the lower right corner drawing scale,

 scale the icon above is triggered measurement acquisition function keys, the keys can be used in th

e according to user's mobile location, Put it in a more convenient place.Click the button to start the 

measurement function, as shown in Fig. 4.1-2.Below the drawing area are the measurement attribut

e roll call and coding input positions, as well as the antenna height Settings and the entrance to the c

oordinate point library. 

 

Figure 4.1 1 figure 4.1 2 

Click Settings Icon, enter the measurement setting interface, as shown in Figure 4.1-3. The limit

ation conditions of measurement and collection are set here, such as solution state, HRMS, VRMS, 

PDOP, differential delay, etc. Users can set the limitation conditions according to the accuracy requ

irements of the operation. The setting of smoothing points is to collect the average value of multiple

 anchor points to indicate the accuracy. You can also set default roll call and default encoding. Setti

ng the information display is to set the content displayed in the status information bar. Users can set

 the information displayed according to their priorities, as shown in Figure 4.1-4.Function menu sett

ing is to display common function Settings to the left menu bar according to the needs of users in th

e process of operation, so that users can call some functions quickly and conveniently.These feature

s include: tilt measuring switch selector switch, network map, drawing zoom in the full positioning 

center, take the screen, such as CAD text annotation, length, area measurement, the drawing set the 
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background color, CAD layer set, the function such as coordinate transformation tool, calculator too

l, click on the left side of the menu icon to trigger the corresponding function. 

Measuring a collection point usually requires entering a roll call and a code click The icon can se

lect the preset code in the code base for quick filling of ground object attributes, as shown in Figure 

2.1-6. If there are many codes in the code library, the codes that are used more frequently will be dis

played in the front for users to quickly select. 

Click the antenna height display to modify and edit the antenna height information, as shown in Fig

ure 2.1-7.The antenna height is set to obtain the actual position of the measurement target on the gro

und by subtracting the antenna height from the phase center coordinates of GNSS.If the antenna inf

ormation is incorrect, click the antenna information to select the correct antenna type in antenna Ma

nagement (used when the GNSS device does not output antenna information or external antenna is 

used), as shown in Figure 2.1-8. 

 

Figure 4.1-3              Figure 4.1-5                   Figure 4.1-6 
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Figure 4.1-6              Figure 4.1-7                  Figure 4.1-8 

4.2 Detail Survey 

Click [Survey] -> [Detail Survey], as shown in Fig.4.2-1. This function is similar to point measurem

ent, but without the graphical interface of point measurement, the content required for measurement

 of collection points can be displayed more concisely and intuitively. This feature can be used to me

asure the collection point directly when the user does not need a drawing reference. The lower part 

of the interface is the function entrance of measurement Settings, point library and tilt measurement 

switch. 
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Figure 4.2-1 

4.3 Control Point Survey 

Click [Survey] – [Control Point Survey], as shown in figure 4.3-1, sometimes need to measure a hig

h accuracy point, collecting the points need to reset the device for many times, asking for a fixed sol

ution for a period of time after acquisition, and need to collect a lot of points, through a certain way 

of calculation, playing in addition to the average value of the deflection point, A high-precision anc

hor point is obtained by taking the average value of the basic several optimal values. The points coll

ected by this method have high accuracy guarantee, and we call this type of points as control points.

In the control point measurement interface, all coordinate points collected by the control point are di

splayed in the middle area in real time, and the graph distribution of the measurement points of the 

control point can be seen, so the precision of the control point can be judged in a certain program.T

he two ICONS below the figure are the measurement Settings and point library function entrance re

spectively. 

Measurement Settings, as shown in FIG. 4.2-2, in addition to setting acquisition limit, control point 

acquisition parameters, such as smoothing points, smoothing interval, repetition times, etc. 

After the control point measurement is completed, the measurement result page will pop up, as sho

wn in Fig.4.2-3, showing the measurement analysis and results of the control point, observation tim

e, pass rate, whether the control point meets the accuracy requirements, etc. 
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Figure 4.3-1                  Figure 4.3-2                Figure 4.3-3 

4.4 Point Stakeout 

Click [Survey] -> [Point Stakeout] to enter the interface of stake point library, as shown in FIG. 4.4-

1. Point stake means to find the location of points through coordinate points in the field site under th

e condition that point coordinates are known. Unstaked points and staked points will be displayed in

 the points. Click stake points to remove stakeed points, view details and stakeed points. Stake point

s are part of the coordinate point library, and the operation of adding and removing stake points is c

onsistent with the coordinate point library. You can also select points in coordinate points (all points

 in the coordinate point library) to stake. After selecting a point for stake, enter the stake interface, a

s shown in Figure 4.4-2. 

Point stake interface layout is similar to point measurement, but there are some differences, in the st

atus information bar to display the value of the target, northwest, southeast deviation value of fill. C

ompass Compass is not in the upper right corner of the drawing area and is currently positioned tog

ether. At the bottom of the drawing area, in addition to the measurement Settings function, there are 

also stake the nearest point, stake point, stake next point these functions. 

In addition to measurement Settings, information display Settings and function menu Settings in poi

nt measurement, the settings also include stake Settings, as shown in Figure 4.4-3. You can set the t

arget according to the southeast, northwest or around the reference direction can be the front directi

on of the host or according to the known reference point direction, in addition, you can set the prom

pt range, stake limit difference, etc. 

How to get to the target point faster? 

If the user has a good sense of direction, in the real-time field can distinguish between the southeast 

and northwest, stake compass display, you can directly see the continuity of the current anchor point

 and the target point, pointing to which direction to which direction can go past. As shown in Figure
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 4.4-2, the target point Pt4 can be found by walking southwest. 

If the user has a poor sense of direction and can't tell the difference between east, west and west, loo

k at the small arrow of the current position. The small arrow points to the direction of the hand whe

n the hand is flat, as shown in Figure 4.4-2, the current hand is pointing south. You can turn the han

d thin pointing, when the hand thin pointing and the current point and the target point coincide, that 

the hand thin pointing and the target point azimuth is consistent, this time according to the hand thin

 pointing, go forward. 

 

Figure 4.4-1              Figure 4.4-2                  Figure 4.4-3 

In the stake points to be stakeed, click the data item and click Details to enter the detailed informati

on of stake points, including the information of each stake point and the distribution diagram of stak

e targets and stake collection points, as shown in FIG. 4.4-4. 
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Figure 4.4-4  

4.5 CAD 

Click [Survey] -> [CAD], as shown in Fig.4.5-1. CAD functions include CAD graphic display, dra

wing of ICONS such as lines, broken lines, arcs and polygons, graphic calculation, import and expo

rt of DXF and DWG graphics, layer management and stake of CAD graphics. 

Click on the Enter CAD layer management, as shown in Figure 4.5-2. You can create and delete

 layers, set whether layers are visible, import DXF and DWG drawings, export DXF files, and set a 

layer as a working layer. 

Click on the Create a figure, as shown in Figure 4.5-1. Including line segment, broken line, arc, p

olygon, two-point fixed square, center point + length fixed square, three-point fixed rectangle, cente

r point + length + width fixed rectangle, center point + radius fixed circle, three-point circle, curve a

nd other types of graphics. You can draw a new graph directly in the drawing area, and point elemen

ts can select existing points or freely take points from the screen. 

Click on the Perform some CAD tool calculations, as shown in Figure 4.5-3. Including two circl

e intersection point, two lines intersection point, two arbitrary graph intersection point, distance offs

et point calculation, element translation, according to the number of equal points, according to the d

istance calculation point, element reverse and line extension and other functions. 

After selecting the CAD figure, see Figure4.5-4. You can delete graphics, view details, stake and ot

her operations. 

After selecting elements, click Stake to enter stake CAD interface, as shown in FIG. 4.5-5. Stake is t

o find the location of the target coordinates in the actual location, stake operation is similar to point 
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stake, line stake. 

 

FIG. 4.5-1                   FIG. 4.5-2                   FIG. 4.5-3 

 

Figure 4.5-1              figure 4.5-2 
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4.6 Line Stakeout 

Click [Survey] -> [Line Stakeout] to enter the interface of line library, as shown in Figure 4.6-1. Lin

e stake is to provide a designed line, input it into the line library, and perform field stake on the line.

 Points on a straight line can be stakeed point by point according to real-time stake mileage, skew di

stance, height difference, etc., or by dividing the line into points at a certain interval. 

Line library management, can add, delete, import, export line data; Create a line, as shown in Figure

 4.6-2. Output the line name and set the starting point and ending point coordinates, and create a lin

e by starting point + azimuth + length. Click on the Select point data from the coordinate point l

ibrary and click point information to enter the point editing interface, as shown in Figure 4.6-3. 

Click the line list item to delete the edit stake line. Click Stake, as shown in Figure 4.6-4. You can s

et stake in the form of line or point by point. If it is point by point, you need to set the calculation m

ethod according to pile number or the whole pile distance, distance interval and whether to automati

cally stake the nearest point. 

Then press OK to enter the line stake interface, as shown in Figure 4.6-5. Can operate through the 

menu stake a line, a line, a point, a point, etc. 

Stake point by point, sometimes need to stake calculation outside the point, need to specify the rang

e and offset stake point, this is called piling, click Pile stake, as shown in Figure 4.6-6. 

 

Figure 4.6-1                Figure 4.6-2                 Figure 4.6-3 
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Figure 4.6-4                Figure 4.6-5                  Figure 4.6-6 

4.7 DSM Stakeout 

Click [Survey] -> [DSM Stakeout], as shown in Fig.4.7-1. According to the existing site triangulatio

n data, the current positioning coordinates are used to carry out elevation stake of the site to determi

ne whether the real-time site at a certain location needs to be filled or dig. 

The site elevation database can be created, imported, edited and deleted, etc., and the site elevation f

ile can be created, as shown in Fig.4.7-2 and 4.7-3. The coordinate of triangulation net file can be in

put manually, also can choose from the point library with batch, can adjust the order of point coordi

nate up and down, also can import coordinate and so on. 

Click the site elevation database data item to edit and delete the elevation file, and click the stake to 

enter the elevation stake interface, as shown in FIG. 4.7-4. 
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Figure 4.7-1              Figure 4.7-2                  Figure 4.7-3 

 

Figure 4.7-4 
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5.8 Road design stake 

Click [survey] - > [Stake Road] into the interface, as shown in figure 5.8-1, by way of plane curve a

nd vertical curve, chain scission, standard cross-sectional, ultra-high, widen design, slope design ele

ments such as data file, according to the circuit design documents and GNSS satellite positioning, T

hread construction stake, section data collection and a series of road thread related applications.It is 

suitable for data survey and collection, line construction, line acceptance and other engineering oper

ations of highway and railway lines at all levels. 

Road design, as shown in Figure 4.8-2. The elements of road design include flat curve, vertical curv

e, chain break, standard cross section, slope, standard cross section includes the elevation and widen

ing of section plate, etc. 

1. Flat curve design: as shown in Figure 4.8-3.The flat curve is the center line of the road, which is t

he direction of the whole road.The methods of flat curve design are linear element method, intersect

ion point method and coordinate method.All roads are composed of road starting points, straight lin

es, relaxation curves, and circular curves.The line element method is a design line formed by directl

y inputting the elements of the road, in which the starting point contains the starting distance and sta

rting point coordinates, the straight line contains the starting azimuth of the element and the length 

of the line, the easing curve contains the starting azimuth of the element and the starting and ending 

radius and the length of the curve, and the circular curve contains the starting azimuth of the elemen

t and the radius and the length.In general, the end azimuth of the former element is equal to the start

ing azimuth of the next element, the radius of the connecting end of the easing curve and the straigh

t line is infinite, and the radius of the connecting end of the easing curve and the circle is equal to th

e circle radius.Intersection point method is to calculate the combination of road design elements thr

ough some algorithms through the coordinates of control points and corresponding easing curve len

gth, easing curve parameters, circle radius and other parameters.The coordinate method calculates t

he combination of road design elements according to the coordinate points on the line and the radius

 of the arc before the coordinate points according to a certain algorithm. The road generated by the c

oordinate method only has the starting point, straight line and arc, which is a simplified line without

 easing curve. 

2. Vertical curve design: as shown in Figure 4.8-4. The vertical curve is the elevation fluctuation of t

he road center line at each mileage. It is the design height of the line center line, which needs to inp

ut the elevation corresponding to each mileage of the line elevation change point and the arc radius 

corresponding to the slope change point. The software calculates the elevation value of the line at ea

ch mileage point according to these design elements. 

3. Chain break design: as shown in Figure 4.8-5.In the process of circuit design, sometimes in adva

nce design good lines due to the actual environmental conditions do not allow the building or constr

uction cost is too high, had to be somewhere to local modification of circuit design, circuit changes, 

line may be long or short, than the original line at this time in order to modify the line behind the de

sign of the mileage data remains unchanged, then use broken, Broken chains are divided into long a

nd short chains.At a certain mileage point, start using a new mileage value, leaving the mileage data

 following this mileage value unchanged. 

4. Standard cross section design: as shown in FIG. 4.8-6.In the actual construction road, the road ce

nter line is only the planning direction of the line, and the actual road includes motor vehicle lane, n

on-motor lane, green belt, sidewalk and other road plates for various purposes.The width, slope and 

other parameters of the whole road of these plates are called the standard cross section.In a real-tim

e way, because of the influence of the built environment, often cannot be built according to the stan

dard cross section, sometimes some plates may need to start at a particular narrow width, sometimes
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 due to the large road camber, extensions to slope safety need somewhere, there needs to be widene

d parameters Settings section plate high, as shown in figure 4.8-7.Ultra wide set according to the ne

eds of each plate, add according to the changing mileage. 

5. Slope design: as shown in Fig.4.8-8. In the actual process of road construction, in addition to buil

ding the road outside of the main road, the road may through the mountain, lake and road environm

ent of the elevation difference is large, if after the mountain digging up roads could lead to a mounta

in fall damage road, so I need to fill the lake mountain and according to certain standard building sl

ope, protect the road. 

If the roads according to the above elements design, is a complete line of design, sometimes differe

nt need only part of the basic construction units, will not have all the design data, users according to

 their own actual project requirements in terms of design, good road design can be used after the roa

d design documents for construction work. 

Note: in order to facilitate road design editing, the software supports road import in various formats,

 which are not described here. 

 

Figure 4.8-1               Figure 4.8-2                  Figure 4.8-3 
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FIG. 4.8-4                    FIG.4.8-5                   FIG. 4.8-6 

 

Figure 4.8-7               figure 4.8-8 

Road stake: the design of the road line files, construction operations. 
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Figure 4.8-9 shows the stake of a road center line. The stake interface and operation are similar to p

oint stake and line stake. Click line stake to switch to other stake modes, including line stake point b

y point, cross section stake, cross section measurement and other road stake related operation functi

ons. 

Line stake point by point, as shown in Figure 4.8-10.Click the function menu icon below to enter th

e measurement Settings, enter the stake library, stake the upper point, stake the next point, piling an

d so on.The stake library is displayed, as shown in Figure 4.8-11.You can select a point in the base f

or stake, or automatically stake the nearest point, and recalculate the pile-by-pile coordinate points o

f the road center line, as shown in Figure 4.8-12.Set the coordinate point according to the whole pile

 number or the whole pile distance, and calculate the coordinate point according to a certain mileage

 deviation distance.You can also set up a calculation of the left and right side pile with stake. 

Measure the cross section, as shown in Figure 4.8-13. According to a certain mileage interval, colle

ct the elevation data of the section of the road line and its surroundings, which can be used for the p

reliminary survey work of the road construction, calculate the amount of road earthwork and evalua

te the construction cost. 

 

Figure 4.8-9               Figure 4.8-10                Figure 4.8-11 
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Figure 4.8-12            figure 4.8-13 

Tools 

On the main interface, click Tools, as shown in Figure 5-1. The tools include coordinate conversion,

 Angle conversion, perimeter area calculation, calculator and other common measurement tools. 
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Figure 5-1 

5.1 Coordinate Converter 

Click [Tools] -> [Coordinate Converter], as shown in Fig.5.1-1 and 5.5-2. The coordinate system pa

rameters set by the current project are used to convert the coordinates of plane, geodetic and space. 

Click on the You can select a point from the point library to perform the calculation transformat

ion, and you can save the calculation point to the point library. 
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Figure 5.1              1 figure 5.1 2 

5.2 Angle Converter 

Click [Tools] -> [Angle Converter], as shown in Figure 5.2-1.Through the function of degree, degre

e minute second, radian and other Angle display formats before the transformation, select input one 

of the formats, calculate the value of the other formats. 
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Figure 5.2 1 

5.3 Perimeter and Area 

Click [Tools] -> [Perimeter and Area], as shown in Figure 5.3-1. You can add and delete coordinate

 points, import and export coordinate points, and view the block graph in the preview view, as show

n in Figure 5.3-2. Click to calculate, as shown in Figure 5.3-3. 
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Figure 5.3-1              Figure 5.3-2                    Figure 5.3-2 

5.4 Calculator 

Click "Tools" -> "Calculator", as shown in Figure 5.4-1. Do some simple math. 

 

Figure 5.4-1 


